طی 24 ساعت گذشته دو مشکل امنیتی خیلی خطرناک در سرورهای لینوکسی کشف شده است

   نویسنده: تیم فنی
1393/07/05
اغلب سایتهایی که از جوملا یا وردپرس یا هر نرم افزار متن باز تحت لینوکسی استفاده می کنند توسط 2 حفره ی امنیتی خیلی خطرناک قابل نفوذ هستند و باید سریعا سرور خود را بروزرسانی کنند.

 

به اشتراک بگذارید: 
 

*توجه : وب سایتهای تحت رایانش ابری سپهر ، هیچ ارتباطی به این مشکل امنیتی ندارد و هیچ گونه جای نگرانی برای کاربرانی که از سپهر برای وب سایت خود استفاده می کنند وجود ندارد *

لینوکس سیستم‌عاملی است که میلیونها کاربر از آن استفاده میکنند. اکثر سایتهایی که از وردپرس یا جوملا استفاده می کنند از این سیستم عامل استفاده می کنند. در ایران به خاطر ارزان بودن هزینه های هاست لینوکسی نسبت به سایر هاست ها اکثر مردم از آن استفاده می کنند.  روز گذشته مشکل امنیتی جدیدی در  پکیج Bash که در همه نسخه های لینوکسی وجود دارد گزارش شده است که می توان از طریق این مشکل امنیتی، دستورات و کامندهای لینوکسی را از راه دور بر روی سرور دیگران اجرا نمود که در گزارش دریافتی درجه اهمیت این باگ از نوع critical  حیاتی می باشد و باید هرچه زودتر نسبت به ایمن سازی این package اقدام نمود.

 

متاسفانه حدود ۱۲ ساعت بعد نیز مشکل دیگری از bash code injection گزارش شد که با وجود ارایه patch باز هم آسیب پذیری بر روی Bash وجود داشت.

Shellshock  از یک اسکریپت Bash برای دسترسی به کامپیوتر شما استفاده می کند. از این طریق، امکان اجرای برنامه ها، فعالسازی ویژگی ها و دسترسی به فایل ها فراهم می شود. این اسکریپت تنها روی سیستم عامل های بر پایه یونیکس، تاثیرگذار است، یعنی فقط لینوکس و مک در مقابل این باگ آسیب پذیر هستند.

ورژنهای لینوکسی که دارای این مشکل امنیتی خطرناک هستند شامل تمامی نسخه هایی که بر پایه RedHat نوشته شده اند است که می توان به سیستم عامل CentOS و کلا تمامی محصولات RedHat اشاره کرد.

 

توصیه می شود در صورتیکه هنوز از تکنولوژی رایانش ابری استفاده نمی کنید . همواره جهت افزایش ضریب امنیتی سایت یا وبلاگ تان، گوش به زنگ مشکلات امنیتی بوده و بلافاصله پس از اینکه این چنین خبرهایی شنیدید وصله های امنیتی شرکت ها را دریافت کرده و در سرور خود نصب کنید.

و البته باید خاطرنشان کنیم که در صورت استفاده از تکنولوژی رایانش ابری:

  • اولا از نرم افزار اوپن سورسی استفاده نمی کنید که نگران پیدا شدن حفره هایی در سورس نرم افزار باشید
  • دوما همواره سایت شما از نظر امنیتی توسط کارشناسان با تجربه ی امنیت مانیتور شده و در صورت نیاز به ترمیم یا بروزرسانی این کار در سریع ترین زمان و توسط متخصص آن برای شما انجام می شود .
  • و سوما به طور اتوماتیک در برنامه ای منظم اطلاعات شما پشتیبانگیری می گردد .

در نتیجه کاربران سپهر بدون هیچ گونه نگرانی در مورد امنیت می توانند از وب سایت خود استفاده کنند .

آیا شما قبلا تجربه ی هک شدن یا از دست رفتن اطلاعات را داشته اید ؟

منابع :

kernelmode  redhat


امتیاز بدهید
به اين مقاله امتیاز بدهید
نظرات کاربران
ارسال نظر
پست های اخیر